Forum:Youtube-Template modernisieren

aus Kamelopedia, der wüsten Enzyklopädie
Wechseln zu: Navigation, Suche
H 15.gif Forum > Youtube-Template modernisieren
Hinweis: Dieser Fred wurde seit 41 Tagen nicht bearbeitet. Dieser Fred ist offiziell versandet - die Diskussion damit Geschichte. Bitte nichts mehr hinzufügen.
Bei Bedarf dann halt einen neuen Fred starten oder diesen notfalls reanimieren.

Diese Frage hatte ich vor Jahren schon mal gestellt, leider bis heute ohne Besserung. Wenn man hier ein Youtube-Video einbindet, so verwendet der generierte HTML-Quelltext die alte API von Youtube. Infolge dessen stehen insbesondere im Firefox-Browser viele Funktionen wie z.B. Vollbild nicht zur Verfügung. Manche Videos werden auch gar nicht abgespielt, dann heißt es "Video nicht verfügbar". Ruft man die selbe Kamelo-Seite mit einem Chrome/Chromium-basierten Browser auf, so sind die Videos dort vorhanden. Das mag ein bisschen Gängelei der Browserkonkurrenz sein, lässt sich aber aus unserer Sicht nur ändern, wenn wir den embed-Code ein bisschen anpassen.

Der jetzige setzt auf den alten embed-Code, der auf das Flashplugin aufbaut. Wenn man wie viele heutige Browserinstallationen kein Flash mehr dabei hat (fliegt ohnehin Ende des Jahres überall raus weil Adobe den Support beendet), dann generiert Firefox eine Art "Workaround" auf Basis von HTML5, das jedoch nicht richtig funktioniert.

Deshalb müsste mal ein Serverkamel schauen, ob sich das Youtube-Template, das hier den Wikicode in HTML umsetzt, entsprechend anpassen lässt. Siehe hier und insbesondere hier.